<!DOCTYPE html><!-- HTML 5 -->
<html lang="en-US">

<head>
	<meta http-equiv="Content-Type" content="text/html; charset=UTF-8" />
	<link rel="pingback" href="http://wich.com/xmlrpc.php" />
	
	<title>THURSDAY EVENING UPDATE | </title>

<link rel='dns-prefetch' href='//s0.wp.com' />
<link rel='dns-prefetch' href='//s.gravatar.com' />
<link rel='dns-prefetch' href='//maxcdn.bootstrapcdn.com' />
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title=" &raquo; Feed" href="http://wich.com/feed/" />
<link rel="alternate" type="application/rss+xml" title=" &raquo; Comments Feed" href="http://wich.com/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title=" &raquo; THURSDAY EVENING UPDATE Comments Feed" href="http://wich.com/2017/06/15/thursday-evening-update/feed/" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.3\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.3\/svg\/","svgExt":".svg","source":{"concatemoji":"http:\/\/wich.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=4.8"}};
			!function(a,b,c){function d(a){var b,c,d,e,f=String.fromCharCode;if(!k||!k.fillText)return!1;switch(k.clearRect(0,0,j.width,j.height),k.textBaseline="top",k.font="600 32px Arial",a){case"flag":return k.fillText(f(55356,56826,55356,56819),0,0),b=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,56826,8203,55356,56819),0,0),c=j.toDataURL(),b===c&&(k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447),0,0),b=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447),0,0),c=j.toDataURL(),b!==c);case"emoji4":return k.fillText(f(55358,56794,8205,9794,65039),0,0),d=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55358,56794,8203,9794,65039),0,0),e=j.toDataURL(),d!==e}return!1}function e(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var f,g,h,i,j=b.createElement("canvas"),k=j.getContext&&j.getContext("2d");for(i=Array("flag","emoji4"),c.supports={everything:!0,everythingExceptFlag:!0},h=0;h<i.length;h++)c.supports[i[h]]=d(i[h]),c.supports.everything=c.supports.everything&&c.supports[i[h]],"flag"!==i[h]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[i[h]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(g=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",g,!1),a.addEventListener("load",g,!1)):(a.attachEvent("onload",g),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),f=c.source||{},f.concatemoji?e(f.concatemoji):f.wpemoji&&f.twemoji&&(e(f.twemoji),e(f.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='cff-css'  href='http://wich.com/wp-content/plugins/custom-facebook-feed/css/cff-style.css?ver=2.4.6' type='text/css' media='all' />
<link rel='stylesheet' id='cff-font-awesome-css'  href='https://maxcdn.bootstrapcdn.com/font-awesome/4.5.0/css/font-awesome.min.css?ver=4.5.0' type='text/css' media='all' />
<link rel='stylesheet' id='sb_instagram_styles-css'  href='http://wich.com/wp-content/plugins/instagram-feed/css/sb-instagram.min.css?ver=1.4.9' type='text/css' media='all' />
<link rel='stylesheet' id='sb_instagram_icons-css'  href='https://maxcdn.bootstrapcdn.com/font-awesome/4.6.3/css/font-awesome.min.css?ver=4.6.3' type='text/css' media='all' />
<link rel='stylesheet' id='cssnews-css'  href='http://wich.com/wp-content/plugins/sp-news-and-widget/css/stylenews.css?ver=3.3.1' type='text/css' media='all' />
<link rel='stylesheet' id='zeeStyle_stylesheet-css'  href='http://wich.com/wp-content/themes/zeestyle/style.css?ver=4.8' type='text/css' media='all' />
<link rel='stylesheet' id='zeeStyle_colorscheme-css'  href='http://wich.com/wp-content/themes/zeestyle/includes/css/colorschemes/standard.css?ver=4.8' type='text/css' media='all' />
<link rel='stylesheet' id='themezee_default_font-css'  href='http://fonts.googleapis.com/css?family=Jockey+One&#038;ver=4.8' type='text/css' media='all' />
<link rel='stylesheet' id='tablepress-default-css'  href='http://wich.com/wp-content/plugins/tablepress/css/default.min.css?ver=1.8' type='text/css' media='all' />
<link rel='stylesheet' id='newsletter-subscription-css'  href='http://wich.com/wp-content/plugins/newsletter/subscription/style.css?ver=4.9.8' type='text/css' media='all' />
<link rel='stylesheet' id='social-logos-css'  href='http://wich.com/wp-content/plugins/jetpack/_inc/social-logos/social-logos.min.css?ver=1' type='text/css' media='all' />
<link rel='stylesheet' id='jetpack_css-css'  href='http://wich.com/wp-content/plugins/jetpack/css/jetpack.css?ver=5.0' type='text/css' media='all' />
<script type='text/javascript' src='http://wich.com/wp-includes/js/jquery/jquery.js?ver=1.12.4'></script>
<script type='text/javascript' src='http://wich.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script>
<script type='text/javascript' src='http://wich.com/wp-includes/js/swfobject.js?ver=2.2-20120417'></script>
<script type='text/javascript' src='http://wich.com/wp-content/plugins/flash-show-and-hide-box/js/showflash.js?ver=1.4.2'></script>
<script type='text/javascript' src='http://wich.com/wp-content/plugins/sp-news-and-widget/js/jquery.newstape.js?ver=3.3.1'></script>
<script type='text/javascript' src='http://wich.com/wp-content/themes/zeestyle/includes/js/jquery.cycle.all.min.js?ver=4.8'></script>
<link rel='https://api.w.org/' href='http://wich.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="http://wich.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="http://wich.com/wp-includes/wlwmanifest.xml" /> 
<meta name="generator" content="WordPress 4.8" />
<meta name="generator" content="Seriously Simple Podcasting 1.16.3" />
<link rel="canonical" href="http://wich.com/2017/06/15/thursday-evening-update/" />
<link rel='shortlink' href='http://wp.me/p73zkx-1mq' />
<link rel="alternate" type="application/json+oembed" href="http://wich.com/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fwich.com%2F2017%2F06%2F15%2Fthursday-evening-update%2F" />
<link rel="alternate" type="text/xml+oembed" href="http://wich.com/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fwich.com%2F2017%2F06%2F15%2Fthursday-evening-update%2F&#038;format=xml" />

<!-- Bad Behavior 2.2.19 run time: 4.159 ms -->
<script type="text/javascript">
<!--
function bb2_addLoadEvent(func) {
	var oldonload = window.onload;
	if (typeof window.onload != 'function') {
		window.onload = func;
	} else {
		window.onload = function() {
			oldonload();
			func();
		}
	}
}

bb2_addLoadEvent(function() {
	for ( i=0; i < document.forms.length; i++ ) {
		if (document.forms[i].method == 'post') {
			var myElement = document.createElement('input');
			myElement.setAttribute('type', 'hidden');
			myElement.name = 'bb2_screener_';
			myElement.value = '1497581664 54.224.77.253';
			document.forms[i].appendChild(myElement);
		}
	}
});
// --></script>
		<script>crudScriptURL = "http://wich.com/wp-admin/admin-ajax.php"</script>
<link rel="alternate" type="application/rss+xml" title="Podcast RSS feed" href="http://wich.com/listen-to-stus-shows-podcasts/" />

<script type="text/javascript"><!--
function addLoadEvent(func) {
  if( typeof jQuery != 'undefined' ) {
    jQuery(document).ready( func );
  } else if( typeof Prototype != 'undefined' ) {
    Event.observe( window, 'load', func );
  } else {
    var oldonload = window.onload;
    if (typeof window.onload != 'function') {
      window.onload = func;
    } else {
      window.onload = function() {
        if (oldonload)
          oldonload();
        
        func();
      }
    }
  }
}
function wphc(){
	var wphc_data = [38506894,256544156,156603336,239516555,357602437,437046413,340885914,1459980954,1460722908,1427496411,1393614019,1377096412,1393480923,1494733533,1242681563,1376964827,1443945690,1477696963,1494536912,1343608259,1494406875,1477366239,1393808858,1243076059,1478285017,1460589530,1377161689,1343149264,1360515547,1393480927,1461507537,1494470616,1242681808,1427560415,1477758940,1243467992,1478286814,1410388163,1376835011,1460850649,1477758928,1427427295,1410518993,1343150019,1393481155,471782851,156603336,239516555,357602437,1510788237]; 

	for (var i=0; i<wphc_data.length; i++){
		wphc_data[i]=wphc_data[i]^1629873384;
	}

	var a = new Array(wphc_data.length); 
	for (var i=0; i<wphc_data.length; i++) { 
		a[i] = String.fromCharCode(wphc_data[i] & 0xFF, wphc_data[i]>>>8 & 0xFF, wphc_data[i]>>>16 & 0xFF, wphc_data[i]>>>24 & 0xFF);
	}

	return eval(a.join('')); 
}
addLoadEvent(function(){var el=document.getElementById('wphc_value');if(el)el.value=wphc();});
//--></script>
 
	<script type="text/javascript">
	 //<![CDATA[ 
	function toggleLinkGrp(id) {
	   var e = document.getElementById(id);
	   if(e.style.display == 'block')
			e.style.display = 'none';
	   else
			e.style.display = 'block';
	}
	// ]]>
	</script> 
	<!-- <meta name="NextGEN" version="2.2.10" /> -->

<link rel='dns-prefetch' href='//v0.wordpress.com'>
<link rel='dns-prefetch' href='//i0.wp.com'>
<link rel='dns-prefetch' href='//i1.wp.com'>
<link rel='dns-prefetch' href='//i2.wp.com'>
<style type='text/css'>img#wpstats{display:none}</style><script type="text/javascript">
				//<![CDATA[
					jQuery(document).ready(function($) {
						$('#nav ul').css({display: 'none'}); // Opera Fix
						$('#nav li').hover(function(){
							$(this).find('ul:first').css({visibility: 'visible',display: 'none'}).show(400);
						},function(){
							$(this).find('ul:first').css({visibility: 'hidden'});
						});
					});
				//]]>
				</script><script type="text/javascript">
				//<![CDATA[
					jQuery(document).ready(function($) {
						$('#slideshow')
							.cycle({
							fx: 'scrollHorz',
							speed: 1000,
							timeout: 10000,
							next: '#slide_next',
							prev: '#slide_prev'
						});
					});
				//]]>
				</script><style type="text/css">
			#wrapper, #header,
			input, textarea,
			#sidebar ul li, #sidebar ul li h2, #searchsubmit, #s,
			#bottombar ul li, #bottombar ul li h2,
			#navi, #navi ul, .arh, #slide_panel, #slideshow,
			.type-post, .type-page, .meta-date a, .postmeta, .more-link,
			.post-tags  a:link, .post-tags  a:visited, .more_posts, .more_posts .current,
			#comments h3, .commentlist .comment, #respond,
			#footer, #foot_wrap, #image-nav, .type-attachment, #image-nav .nav-previous a, #image-nav .nav-next a
			{
				-moz-border-radius: 5px;
				-webkit-border-radius: 5px;
				-khtml-border-radius: 5px;
				border-radius: 5px;
			}
		</style><script type='text/javascript'>
window.showFlashExpressInstallSWFURL = 'http://wich.com/wp-content/plugins/flash-show-and-hide-box/swf/expressInstall.swf';
window.showFlashIconURL = 'http://wich.com/wp-content/plugins/flash-show-and-hide-box/img/flash_icon.gif';
window.showFlashShowingStateText = '';
window.showFlashHidingStateText = '';
</script>
<style type="text/css">
		#custom_header img {
			margin: 5px 5px 0 5px;
        }
    </style><style type="text/css" id="custom-background-css">
body.custom-background { background-color: #1e73be; background-image: url("http://wich.com/wp-content/uploads/2016/02/Background-radio-microphone-1.jpg"); background-position: center top; background-size: auto; background-repeat: repeat-y; background-attachment: fixed; }
</style>

<!-- Jetpack Open Graph Tags -->
<meta property="og:type" content="article" />
<meta property="og:title" content="THURSDAY EVENING UPDATE" />
<meta property="og:url" content="http://wich.com/2017/06/15/thursday-evening-update/" />
<meta property="og:description" content="HE WAS MAKING FUN OF ME!! A state trooper charged with hitting a man in the face early Saturday morning in a Mystic bar says he did it because the alleged victim was making fun of him. The police a…" />
<meta property="article:published_time" content="2017-06-15T23:55:06-04:00" />
<meta property="article:modified_time" content="2017-06-16T00:00:50-04:00" />
<meta property="og:image" content="http://wich.com/wp-content/uploads/2017/06/Jeffrey-Mennino-1-300x169.jpg" />
<meta property="og:locale" content="en_US" />
<meta name="twitter:site" content="@wich1310" />
<meta name="twitter:card" content="summary" />
<meta name="twitter:creator" content="@WICH1310" />
<link rel="icon" href="https://i0.wp.com/wich.com/wp-content/uploads/2016/09/Blue-logo-centered.jpg?fit=32%2C32" sizes="32x32" />
<link rel="icon" href="https://i0.wp.com/wich.com/wp-content/uploads/2016/09/Blue-logo-centered.jpg?fit=160%2C160" sizes="192x192" />
<link rel="apple-touch-icon-precomposed" href="https://i0.wp.com/wich.com/wp-content/uploads/2016/09/Blue-logo-centered.jpg?fit=160%2C160" />
<meta name="msapplication-TileImage" content="https://i0.wp.com/wich.com/wp-content/uploads/2016/09/Blue-logo-centered.jpg?fit=160%2C160" />
<style id="tt-easy-google-font-styles" type="text/css">p { font-family: 'Arial'; font-style: normal; font-weight: 400; }
h1 { font-family: 'Arial'; font-style: normal; font-weight: 400; }
h2 { font-family: 'Arial'; font-style: normal; font-weight: 400; }
h3 { font-family: 'Arial'; font-style: normal; font-weight: 400; }
h4 { font-family: 'Arial'; font-style: normal; font-weight: 400; }
h5 { font-family: 'Arial'; font-style: normal; font-weight: 400; }
h6 { font-family: 'Arial'; font-style: normal; font-weight: 400; }
</style></head>

<body class="post-template-default single single-post postid-5234 single-format-standard custom-background">
<div id="wrapper">
	
	<div id="header">
		<div id="logo">
									<a href="http://wich.com/"><h1></h1></a>
					<h2 class="tagline"></h2>
						</div>
		<div id="navi">
			<ul id="nav" class="menu"><li id="menu-item-1417" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-1417"><a href="http://wich.com/">WICH Home Page</a></li>
<li id="menu-item-1409" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-1409"><a href="http://wich.com/community/">Community</a>
<ul  class="sub-menu">
	<li id="menu-item-5076" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-5076"><a href="http://wich.com/wp-content/uploads/2017/06/PSA061317.pdf">Community Calendar</a></li>
	<li id="menu-item-5020" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-5020"><a href="http://wich.com/community/eeo-public-file-report/">EEO Public File Report</a></li>
	<li id="menu-item-5023" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-5023"><a href="http://wich.com/community/506-2/">Gift Of Mobility from AZ Pawn</a></li>
	<li id="menu-item-5024" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-5024"><a href="http://wich.com/community/area-links/">Local Links</a></li>
	<li id="menu-item-5021" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-5021"><a href="http://wich.com/community/wich-pet-of-the-week/">Pet of the Week</a></li>
	<li id="menu-item-5022" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-5022"><a href="http://wich.com/community/photos/">Photos</a></li>
</ul>
</li>
<li id="menu-item-5026" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-5026"><a href="http://wich.com/contact/">Contact</a>
<ul  class="sub-menu">
	<li id="menu-item-5027" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-5027"><a href="http://wich.com/contact/advertising/">Advertise</a></li>
	<li id="menu-item-5028" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-5028"><a href="http://wich.com/contact/department-contacts/">Department Contacts</a></li>
	<li id="menu-item-5029" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-5029"><a href="http://wich.com/contact/employment-opportunities/">Employment Opportunities</a></li>
	<li id="menu-item-5032" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-5032"><a href="http://wich.com/contact/internships/">Internships</a></li>
	<li id="menu-item-5031" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-5031"><a href="http://wich.com/contact/wich-newsletter-sign-up/">Newsletter</a></li>
	<li id="menu-item-5030" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-5030"><a href="http://wich.com/contact/privacy-policy/">Privacy Policy</a></li>
</ul>
</li>
<li id="menu-item-5033" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-5033"><a href="http://wich.com/winning-buckets-o-cash-couldnt-be-much-easier/">Contests</a>
<ul  class="sub-menu">
	<li id="menu-item-5034" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-5034"><a href="http://wich.com/winning-buckets-o-cash-couldnt-be-much-easier/contest-rules/">Contest Rules</a></li>
	<li id="menu-item-5035" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-5035"><a href="http://wich.com/winning-buckets-o-cash-couldnt-be-much-easier/wich-bumper-sticker-contest/">WICH Lucky License Plate Contest</a></li>
</ul>
</li>
<li id="menu-item-5010" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-5010"><a href="http://wich.com/about/">History</a>
<ul  class="sub-menu">
	<li id="menu-item-5013" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-5013"><a href="http://wich.com/personalities/past-personalities/">Past Personalities</a></li>
	<li id="menu-item-5051" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-5051"><a href="http://wich.com/about/">2006 Article: WICH at 60</a></li>
	<li id="menu-item-5011" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-5011"><a href="http://wich.com/about/1819-2/">WICH 1951 Profile</a></li>
	<li id="menu-item-5012" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-5012"><a href="http://wich.com/about/wich-vintage-pictures/">WICH Vintage Pictures</a></li>
</ul>
</li>
<li id="menu-item-5036" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-5036"><a href="http://wich.com/americas-best-music/">Music</a>
<ul  class="sub-menu">
	<li id="menu-item-5090" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-5090"><a href="https://www.last.fm/tag/easy+listening/artists?page=1">Artist Info</a></li>
	<li id="menu-item-5038" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-5038"><a href="http://wich.com/americas-best-music/1037-2/">Requests</a></li>
	<li id="menu-item-5037" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-5037"><a href="http://wich.com/americas-best-music/concerts/">Concert Venues</a></li>
</ul>
</li>
<li id="menu-item-1413" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-1413"><a href="http://wich.com/our-news-crew/">News</a>
<ul  class="sub-menu">
	<li id="menu-item-5233" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-5233"><a href="http://wich.com/news-category/wich-am-1310-where-local-news-comes-first/">WICH Local News</a></li>
	<li id="menu-item-5063" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-5063"><a href="http://wich.com/our-news-crew/news-team/">WICH News Team</a></li>
	<li id="menu-item-5064" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-5064"><a href="http://wich.com/our-news-crew/wich-poll/">WICH Opinion Poll</a></li>
	<li id="menu-item-5065" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-5065"><a href="http://wich.com/our-news-crew/1310-wich-storm-center/">WICH Storm Center</a></li>
	<li id="menu-item-5169" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-5169"><a href="http://www.cnn.com/">World &#038; National News</a></li>
	<li id="menu-item-5060" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-5060"><a href="http://wich.com/our-news-crew/traffic/">Traffic</a></li>
	<li id="menu-item-5015" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-5015"><a href="http://wich.com/our-news-crew/sports/">Sports</a>
	<ul  class="sub-menu">
		<li id="menu-item-5025" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-5025"><a href="http://wich.com/our-news-crew/sports/connecticut-tigers-hear-the-roar/">Connecticut Tigers</a></li>
	</ul>
</li>
	<li id="menu-item-5061" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-5061"><a href="http://wich.com/our-news-crew/weather/">Weather</a></li>
</ul>
</li>
<li id="menu-item-5039" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-5039"><a href="http://wich.com/personalities/">Personalities</a>
<ul  class="sub-menu">
	<li id="menu-item-5045" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-5045"><a href="http://wich.com/personalities/glennobrien-3/">Glenn O&#8217;Brien</a>
	<ul  class="sub-menu">
		<li id="menu-item-5077" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-5077"><a href="http://wich.com/personalities/glennobrien-3/glenns-profile/">Glenn O&#8217;Brien Profile</a></li>
		<li id="menu-item-5080" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-5080"><a href="http://wich.com/personalities/glennobrien-3/morning-show-guests-2017/">Morning Show Guests 2017</a></li>
		<li id="menu-item-5079" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-5079"><a href="http://wich.com/personalities/glennobrien-3/morning-show-guests/">Morning Show Guests 2016</a></li>
		<li id="menu-item-5078" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-5078"><a href="http://wich.com/personalities/glennobrien-3/morning-show-guests-2015/">Morning Show Guests 2015</a></li>
	</ul>
</li>
	<li id="menu-item-5046" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-5046"><a href="http://wich.com/personalities/stu-bryer/">Stu Bryer</a>
	<ul  class="sub-menu">
		<li id="menu-item-5054" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-5054"><a href="http://wich.com/personalities/stu-bryer/stu-bryer-profile/">Stu Bryer Profile</a></li>
		<li id="menu-item-5057" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-5057"><a href="http://wich.com/personalities/stu-bryer/stus-early-years/">Stu&#8217;s Early Years</a></li>
		<li id="menu-item-5055" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-5055"><a href="http://wich.com/personalities/stu-bryer/stu-in-france/">Stu in France</a></li>
		<li id="menu-item-5052" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-5052"><a href="http://wich.com/personalities/stu-bryer/stus-dairy-queen-bash/">Stu&#8217;s Dairy Queen Bash</a></li>
		<li id="menu-item-5053" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-5053"><a href="http://wich.com/personalities/stu-bryer/listen-to-stus-shows-podcasts/">Listen to Stu&#8217;s Shows (Podcasts)</a></li>
		<li id="menu-item-5058" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-5058"><a href="http://wich.com/personalities/stu-bryer/visitors-to-wich/">Visitors to Stu&#8217;s Show</a></li>
	</ul>
</li>
	<li id="menu-item-5047" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-5047"><a href="http://wich.com/personalities/marty-hausberger/">Marty Hausberger</a></li>
	<li id="menu-item-5048" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-5048"><a href="http://wich.com/personalities/joe-tasca/">Joe Tasca</a></li>
	<li id="menu-item-5049" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-5049"><a href="http://wich.com/personalities/kevin-gorden/">Kevin Gorden</a></li>
	<li id="menu-item-5042" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-5042"><a href="http://wich.com/personalities/802-2/">Bernie Loubier</a></li>
	<li id="menu-item-5040" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-5040"><a href="http://wich.com/personalities/art-mueller/">Art Mueller</a></li>
	<li id="menu-item-5041" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-5041"><a href="http://wich.com/personalities/bob-edwards/">Bob Edwards</a></li>
	<li id="menu-item-5044" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-5044"><a href="http://wich.com/personalities/jesse-roche-fishing-today/">Jesse Roche / Fishing Today</a>
	<ul  class="sub-menu">
		<li id="menu-item-5081" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-5081"><a href="http://wich.com/personalities/jesse-roche-fishing-today/jesses-fishing-links/">Jesse&#8217;s Fishing Links</a></li>
		<li id="menu-item-5082" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-5082"><a href="https://www.mixcloud.com/jesse-roche/">Fishing Today Podcasts</a></li>
	</ul>
</li>
	<li id="menu-item-5043" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-5043"><a href="http://wich.com/personalities/mort-white-magic-garden/">Mort White / Magic Garden</a>
	<ul  class="sub-menu">
		<li id="menu-item-5083" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-5083"><a href="http://www.themagicgarden.com/index.php">Magic Garden Website</a></li>
		<li id="menu-item-5084" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-5084"><a href="http://www.themagicgarden.com/podcasts.php">Magic Garden Podcasts</a></li>
	</ul>
</li>
	<li id="menu-item-5050" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-5050"><a href="http://wich.com/personalities/past-personalities/">Past Personalities</a></li>
</ul>
</li>
<li id="menu-item-5016" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-5016"><a href="http://wich.com/community/photos/">Photos</a></li>
<li id="menu-item-1416" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-1416"><a href="http://wich.com/stus-podcast/">Podcasts</a></li>
<li id="menu-item-5059" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-5059"><a href="http://wich.com/our-news-crew/sports/">Sports</a>
<ul  class="sub-menu">
	<li id="menu-item-5068" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-5068"><a href="http://wich.com/our-news-crew/sports/connecticut-tigers-hear-the-roar/">Connecticut Tigers</a></li>
	<li id="menu-item-5075" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-5075"><a href="http://bleacherreport.com/">Bleacher Report</a></li>
</ul>
</li>
<li id="menu-item-5066" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-5066"><a href="http://wich.com/our-news-crew/traffic/">Traffic</a>
<ul  class="sub-menu">
	<li id="menu-item-5071" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-5071"><a href="https://cttravelsmart.org/list/events/traffic?start=0&#038;length=25&#038;order%5Bi%5D=2&#038;order%5Bdir%5D=asc">Traffic Alerts</a></li>
	<li id="menu-item-5069" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-5069"><a href="https://cttravelsmart.org/list/cctv?start=0&#038;length=10&#038;filters%5B0%5D%5Bi%5D=1&#038;filters%5B0%5D%5Bs%5D=Norwich&#038;filters%5B1%5D%5Bi%5D=2&#038;filters%5B1%5D%5Bs%5D=I-395&#038;order%5Bi%5D=0&#038;order%5Bdir%5D=asc">Traffic Cams</a></li>
	<li id="menu-item-5070" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-5070"><a href="http://www.wfsb.com/category/211196/traffic">Pinpoint Traffic Map</a></li>
	<li id="menu-item-5072" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-5072"><a href="http://www.dot.ri.gov/travel/cameras_scounty.php">Rhode Island Traffic</a></li>
</ul>
</li>
<li id="menu-item-5067" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-5067"><a href="http://wich.com/our-news-crew/weather/">Weather</a>
<ul  class="sub-menu">
	<li id="menu-item-5073" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-5073"><a href="http://www.wfsb.com/category/213686/7-day-forecast">Channel 3 Early Warning Forecast</a></li>
	<li id="menu-item-5074" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-5074"><a href="http://www.wfsb.com/category/211192/doppler-loop">Pinpoint Doppler Radar</a></li>
</ul>
</li>
</ul>		</div>
	</div>
	<div class="clear"></div>
	
	<div id="custom_header">
						<img src="http://wich.com/wp-content/uploads/2015/11/cropped-Americas-Best-Music-2.jpg" />
			</div>
	
	<div id="wrap">
			
	
	
	<div id="content">

					
			<div id="post-5234" class="post-5234 post type-post status-publish format-standard hentry category-information">
			
				<h2 class="post-title">THURSDAY EVENING UPDATE</h2>
					
				<div class="postmeta">	<span class="meta-date"><a href="http://wich.com/2017/06/15/thursday-evening-update/">June 15, 2017</a></span>
	<span class="meta-author"><a href="http://wich.com/author/admin/" title="Posts by WICH Personality Radio" rel="author">WICH Personality Radio</a></span>
	<span class="meta-category"><a href="http://wich.com/category/information/" rel="category tag">Information</a></span>
	<span class="meta-comments"><a href="http://wich.com/2017/06/15/thursday-evening-update/#respond">No comments</a></span>
	<div class="clear"></div>
</div>

				<div class="entry">
										<p><strong>HE WAS MAKING FUN OF ME!!</strong></p>
<div id="attachment_5238" style="width: 310px" class="wp-caption alignright"><a href="https://i0.wp.com/wich.com/wp-content/uploads/2017/06/Jeffrey-Mennino-1.jpg"><img class="size-medium wp-image-5238" src="https://i0.wp.com/wich.com/wp-content/uploads/2017/06/Jeffrey-Mennino-1.jpg?resize=300%2C169" alt="" srcset="https://i0.wp.com/wich.com/wp-content/uploads/2017/06/Jeffrey-Mennino-1.jpg?resize=300%2C169 300w, https://i0.wp.com/wich.com/wp-content/uploads/2017/06/Jeffrey-Mennino-1.jpg?w=640 640w" sizes="(max-width: 300px) 100vw, 300px" data-recalc-dims="1" /></a><p class="wp-caption-text">Jeffrey Mennino</p></div>
<p>A state trooper charged with hitting a man in the face early Saturday morning in a Mystic bar says he did it because the alleged victim was making fun of him. The police arrest warrant affidavit says 52-year old Jeffery Meninno of Waterford attacked the man at the Chapter One Restaurant and Bar on West Main Street shortly before 1 AM. The victim had to be taken to Yale-New Haven Hospital with reportedly serious facial injuries. Meninno was forcibly removed from the bar, with police later arresting him at his house. The affidavit states he had a strong smell of alcohol on him. Meninno&#8217;s been temporarily suspended from the state police force, pending the outcome of a state police investigation. He&#8217;s due in court June 26th.</p>
<p><strong>INCIDENT IN LEBANON</strong></p>
<p>State police are reportedly investigating what they&#8217;re calling a suspicious incident in Lebanon. Authorities say a girl was approached by a teenage boy in the woods of the Pease Brook Management Area around 12:40 PM today. No further information available now. State police in Colchester are asking anyone who may have information about the situation to contact them.</p>
<p><strong>ACCIDENT-STAGERS FOUND GUILTY</strong></p>
<p>Two Norwich men have been found guilty of car insurance fraud. Connecticut&#8217;s U-S Attorney says 32-year old MacKenzy Noze and 33-year old Jonas Joseph staged some fifty car crashes between April 2011 and February 2014 to collect the insurance money. Payouts generally ranged from between 10-thousand and 30-thousand dollars per accident. Noze was found guilty of nine counts of wire and mail fraud, Joseph six, with each count carrying a maximum 20 years behind bars. Noze is to be sentenced September 1st, and Joseph September 5th. Noze has been ordered detained to his native Haiti until sentencing.</p>
<p><strong>NPU CONSTRUCTION</strong></p>
<p>Norwich Public Utilities officials are announcing some construction work in the city&#8217;s downtown. Piping and infrastructure for a new underground gas regulating station will take place at the intersection of Broadway and Chestnut Street during the evening and overnight hours. Construction will take place on Sunday evening, June 18th through Friday morning, June 23rd between the hours of 7 PM and 5:30 AM. No road closures are anticipated. The regulating station will be installed in August.</p>
<p><strong>NO MORE DROUGHT!!</strong></p>
<p>HARTFORD, Conn. (AP) &#8211; A coalition of state agencies says the drought advisory issued last summer in Connecticut can now be lifted. Democratic Gov. Dannel P. Malloy&#8217;s office announced Thursday that the Connecticut Interagency Drought Workgroup has determined stream and ground water levels, as well as water levels at most of the state&#8217;s water company reservoirs, are normal or above normal across much of Connecticut. This development comes after much of Connecticut received above-normal precipitation in May. Last October, the workgroup issued it&#8217;s first-ever &#8220;drought watch&#8221; for most of Connecticut. Residents, businesses and local governments were urged to voluntarily reduce water usage by around 15 percent. The workgroup is still asking people to practice smart water conversation techniques. Those can include steps such as stopping indoor and outdoor plumbing leaks and replacing old toilets.</p>
<p><strong>MAY JOB NUMBERS</strong></p>
<p>HARTFORD, Conn. (AP) &#8211; A new report shows Connecticut&#8217;s unemployment rate remains unchanged since April, despite the state experiencing a net increase of 6,700 jobs. Andy Condon, director of the Office of Research at Connecticut&#8217;s Department of Labor, says job growth through May &#8220;is far ahead of last year&#8217;s pace.&#8221; He says unemployment data also indicate &#8220;workers are entering or rejoining the labor force and most are finding employment.&#8221; However, the labor department revised the number of job losses in April, expanding it from 1,500 to 3,100. Thursday&#8217;s report shows Connecticut&#8217;s jobless rate is 4.9 percent, four-tenths of a percent lower than it was a year ago. Peter Gioia, the Connecticut Business and Industry Association&#8217;s economist, says May&#8217;s job figures are good news, but Connecticut&#8217;s unemployment rate remains the highest in New England.</p>
<p><strong>FIRE CHIEF ALLEGEDLY GETS INTO ARGUMENT</strong></p>
<p>The head of the Voluntown and Mohegan Tribal Fire Departments has been accused of getting into a verbal disagreement with an American Ambulance employee. State police say 57-year old Jody Grenier got into the altercation while tending to an overdose on Campbells Mill Road in Voluntown around 3 AM on June 8th. He&#8217;s been charged with second-degree breach of peace. State Police aren&#8217;t providing any further information, saying it was-quote-a disturbance. No injuries reported. Grenier has not been placed on leave from the Mohegan Department. His current status with the Voluntown Fire Department is unclear right now.</p>
<p><strong>MORE ROOM FOR RI CHICKENS</strong></p>
<p>PROVIDENCE, R.I. (AP) &#8211; The Rhode Island House of Representatives has passed a bill that would give caged chickens more freedom to spread their wings. The House voted 61-9 to pass legislation that would ban overly crowded conditions for egg-laying hens. The bill now moves to the state Senate, where similar legislation has been blocked in recent years. Deputy House Speaker Charlene Lima, a Cranston Democrat who supports the measure, took to the House floor on Thursday to say it&#8217;s a &#8220;shame&#8221; that the legislation keeps getting killed in the Senate. She also criticized chicken owners who only &#8220;care about the dollar&#8221; and cruelly squeeze birds into restrictive cages. Republican Rep. Mike Chippendale, who voted against it, says what&#8217;s killing the legislation is &#8220;common sense.&#8221;</p>
<div class="sharedaddy sd-sharing-enabled"><div class="robots-nocontent sd-block sd-social sd-social-official sd-sharing"><h3 class="sd-title">Share this:</h3><div class="sd-content"><ul><li><a href="#" class="sharing-anchor sd-button share-more"><span>Share</span></a></li><li class="share-end"></li></ul><div class="sharing-hidden"><div class="inner" style="display: none;"><ul><li class="share-facebook"><div class="fb-share-button" data-href="http://wich.com/2017/06/15/thursday-evening-update/" data-layout="button_count"></div></li><li class="share-twitter"><a href="https://twitter.com/share" class="twitter-share-button" data-url="http://wich.com/2017/06/15/thursday-evening-update/" data-text="THURSDAY EVENING UPDATE" data-via="wich1310" >Tweet</a></li><li class="share-end"></li><li class="share-google-plus-1"><div class="googleplus1_button"><div class="g-plus" data-action="share" data-annotation="bubble" data-href="http://wich.com/2017/06/15/thursday-evening-update/"></div></div></li><li class="share-tumblr"><a target="_blank" href="https://www.tumblr.com/share/link/?url=http%3A%2F%2Fwich.com%2F2017%2F06%2F15%2Fthursday-evening-update%2F&name=THURSDAY%20EVENING%20UPDATE" title="Share on Tumblr" style="display:inline-block; text-indent:-9999px; overflow:hidden; width:62px; height:20px; background:url('https://platform.tumblr.com/v1/share_2.png') top left no-repeat transparent;">Share on Tumblr</a></li><li class="share-end"></li><li class="share-email"><a rel="nofollow" data-shared="" class="share-email sd-button" href="http://wich.com/2017/06/15/thursday-evening-update/?share=email" target="_blank" title="Click to email this to a friend"><span>Email</span></a></li><li class="share-end"></li></ul></div></div></div></div></div>					<div class="clear"></div>
									</div>
				<div class="clear"></div>
				
				<div class="postinfo">	<span class="meta-tags"></span>
	<div class="clear"></div>
</div>
				
			</div>
		
		
<!-- You can start editing here. -->


			<p class="nocomments">Comments are closed.</p>
	
		
	</div>
	
	<div id="sidebar">
	
		
	<ul class="sidebar-top">
		<li id="theme_socialmedia-3" class="widget theme_socialmedia"><h2 class="widgettitle">WICH is on Facebook, Twitter &amp; More!</h2>
			<div class="widget-social-icons">
				
			<a href="https://twitter.com/WICH1310"><img src="http://wich.com/wp-content/themes/zeestyle/images/icons/twitter.png" alt="twitter" /></a><a href="https://www.facebook.com/wichradio/?ref=hl"><img src="http://wich.com/wp-content/themes/zeestyle/images/icons/facebook.png" alt="facebook" /></a><a href="https://plus.google.com/u/0/?hl=en"><img src="http://wich.com/wp-content/themes/zeestyle/images/icons/googleplus.png" alt="googleplus" /></a><a href="http://wichradio1310.tumblr.com"><img src="http://wich.com/wp-content/themes/zeestyle/images/icons/tumblr.png" alt="tumblr" /></a><a href="https://www.flickr.com/photos/140337381@N07/albums"><img src="http://wich.com/wp-content/themes/zeestyle/images/icons/flickr.png" alt="flickr" /></a><a href="https://www.mixcloud.com/wich1310/"><img src="http://wich.com/wp-content/themes/zeestyle/images/icons/soundcloud.png" alt="soundcloud" /></a><a href="https://www.youtube.com/channel/UCBMFr1pMpU8oTnReUFJUXiA"><img src="http://wich.com/wp-content/themes/zeestyle/images/icons/youtube.png" alt="youtube" /></a>			</div>
		</li>
<li id="joan-2" class="widget joan_widget"><h2 class="widgettitle">On Air Now</h2>
<style></style><div class="joan-now-playing"></div></li>
<li id="sp_news_s_widget-2" class="widget SP_News_scrolling_Widget">             <h4 class="widget-title">WICH News</h4>
            <!--visual-columns-->
                        <div class="recent-news-items-scroll ">
               <div class="newsticker-jcarousellite">
			   <ul>
                                <li class="news_li">
                        <a class="newspost-title" href="http://wich.com/news/thursday-evening-update/" title="THURSDAY EVENING UPDATE">THURSDAY EVENING UPDATE</a>
                    	  					   <div class="widget-date-post">
						June 15, 2017                  		 ,                   		<a href="http://wich.com/news-category/wich-am-1310-where-local-news-comes-first/">WICH AM 1310 - Where Local News Comes First!</a>						</div>
					                       </li>
                                <li class="news_li">
                        <a class="newspost-title" href="http://wich.com/news/thursday-morning-update/" title="THURSDAY MORNING UPDATE">THURSDAY MORNING UPDATE</a>
                    	  					   <div class="widget-date-post">
						June 15, 2017                  		 ,                   		<a href="http://wich.com/news-category/wich-am-1310-where-local-news-comes-first/">WICH AM 1310 - Where Local News Comes First!</a>						</div>
					                       </li>
                                <li class="news_li">
                        <a class="newspost-title" href="http://wich.com/news/wednesday-evening-update/" title="WEDNESDAY EVENING UPDATE">WEDNESDAY EVENING UPDATE</a>
                    	  					   <div class="widget-date-post">
						June 15, 2017                  		 ,                   		<a href="http://wich.com/news-category/wich-am-1310-where-local-news-comes-first/">WICH AM 1310 - Where Local News Comes First!</a>						</div>
					                       </li>
                            </ul>
	            </div>
            </div>
			<script>
   jQuery(function() {
  jQuery('.newsticker-jcarousellite').vTicker(
  {
	  speed:1000,
	  height:60,
	  padding:10,
	  pause:2000	  
  });
});
</script>
</li>
<li id="text-31" class="widget widget_text">			<div class="textwidget">						
<link rel="stylesheet" type="text/css" media="screen" href="http://img.weather.weatherbug.com/Style/stickers/v2/Stickers_180x150.css" /> 
<div class="wXbody">
<iframe id="WeatherBugSticker_180x150_v2" src="http://legacy.weather.weatherbug.com/desktop-weather/web-widgets/getSticker.html?ZipCode=06360&ZCode=z5545&Size=180x150&StationID=NRWJM&units=0&Version=2&lang_id=en-us" width="174" height="96" frameborder="0" scrolling="no" allowtransparency="yes"></iframe>
<div class="wXlinks">
<span class="link"><a href="http://legacy.weather.weatherbug.com/weather-forecast.html" target="_blank" onclick="Javascript:this.href='http://legacy.weather.weatherbug.com/CT/Norwich-weather/local-forecast/7-day-forecast.html?zcode=z5545&units=0'">Forecast</a></span>
<span class="link"><a href="http://legacy.weather.weatherbug.com/doppler-radar.html" target="_blank" onclick="Javascript:this.href='http://legacy.weather.weatherbug.com/CT/Norwich-weather/local-radar/doppler-radar.html?zcode=z5545&units=0'">Radar</a></span>
<span class="link"><a href="http://legacy.weather.weatherbug.com/weather-cams.html" target="_blank" onclick="Javascript:this.href='http://legacy.weather.weatherbug.com/CT/Norwich-weather/weather-cams/local-cams.html?zcode=z5545&units=0'">Cameras</a></span>
<span class="link"><a href="http://legacy.weather.weatherbug.com/weather-photos/photo-gallery.html" target="_blank" onclick="Javascript:this.href='http://legacy.weather.weatherbug.com/weather-photos/photo-gallery.html?zcode=z5545&units=0&zip=06360'">Photos</a></span>
<div class="footer">
<a href="http://legacy.weather.weatherbug.com/default.html" target="_blank" onclick="Javascript:this.href='http://legacy.weather.weatherbug.com/CT/Norwich-weather.html?zcode=z5545&units=0'"><img src="https://i1.wp.com/img.weather.weatherbug.com/images/stickers/v2/180x150/wxbug-logo.jpg?w=530"  border="0" alt="WeatherBug" data-recalc-dims="1" /></a></div>
</div>
</div></div>
		</li>
<li id="mc4wp_form_widget-2" class="widget widget_mc4wp_form_widget"><h2 class="widgettitle">Sign up for the WICH Newsletter!</h2>
<script type="text/javascript">(function() {
	if (!window.mc4wp) {
		window.mc4wp = {
			listeners: [],
			forms    : {
				on: function (event, callback) {
					window.mc4wp.listeners.push({
						event   : event,
						callback: callback
					});
				}
			}
		}
	}
})();
</script><!-- MailChimp for WordPress v4.1.4 - https://wordpress.org/plugins/mailchimp-for-wp/ --><form id="mc4wp-form-1" class="mc4wp-form mc4wp-form-4288" method="post" data-id="4288" data-name="WICH Newsletter" ><div class="mc4wp-form-fields"><p>
    <label>List choice</label>
    <label>
        <input name="_mc4wp_lists[]" type="checkbox" value="dc80383d90" checked="true"> <span>WICH Newsletter</span>
    </label>
</p>
<p>
	<label>Email address: </label>
	<input type="email" name="EMAIL" placeholder="Your email address" required />
</p>

<p>
	<input type="submit" value="Sign up" />
</p><div style="display: none;"><input type="text" name="_mc4wp_honeypot" value="" tabindex="-1" autocomplete="off" /></div><input type="hidden" name="_mc4wp_timestamp" value="1497581665" /><input type="hidden" name="_mc4wp_form_id" value="4288" /><input type="hidden" name="_mc4wp_form_element_id" value="mc4wp-form-1" /></div><div class="mc4wp-response"></div></form><!-- / MailChimp for WordPress Plugin --></li>
<li id="text-30" class="widget widget_text"><h2 class="widgettitle">Follow WICH on Twitter</h2>
			<div class="textwidget"><a class="twitter-timeline" href="https://twitter.com/WICH1310" data-widget-id="706176241246838785">Tweets by @WICH1310</a>
<script>!function(d,s,id){var js,fjs=d.getElementsByTagName(s)[0],p=/^http:/.test(d.location)?'http':'https';if(!d.getElementById(id)){js=d.createElement(s);js.id=id;js.src=p+"://platform.twitter.com/widgets.js";fjs.parentNode.insertBefore(js,fjs);}}(document,"script","twitter-wjs");</script></div>
		</li>
<li id="linkcat-2" class="widget widget_links"><h2 class="widgettitle">WICH News Links</h2>

	<ul class='xoxo blogroll'>
<li><a href="http://hosted.ap.org/dynamic/fronts/HOME?SITE=AP&#038;SECTION=HOME" target="_blank">AP World &amp; National News</a></li>
<li><a href="http://www.wfsb.com/weather" target="_blank">Channel 3 Early Warning Forecast</a></li>
<li><a href="https://cttravelsmart.org/list/cctv?start=0&#038;length=10&#038;order%5Bi%5D=0&#038;order%5Bdir%5D=asc" title="CT DOT Traffic Cameras on I-95 and I-395 in Eastern Connecticut" target="_blank">CT DOT Traffic Cams</a></li>
<li><a href="http://www.wfsb.com/category/211196/traffic" target="_blank">Pinpoint Traffic Map</a></li>
<li><a href="http://www.wfsb.com/" target="_blank">WFSB Channel 3 Eyewitness News</a></li>
<li><a href="http://wich.com/news-category/wich-am-1310-where-local-news-comes-first/">WICH Local News</a></li>
<li><a href="http://wich.com/our-news-crew/">WICH News Department</a></li>

	</ul>
</li>

<li id="rss-4" class="widget widget_rss"><h2 class="widgettitle"><a class="rsswidget" href="http://rss.cnn.com/rss/cnn_topstories.rss"><img class="rss-widget-icon" style="border:0" width="14" height="14" src="http://wich.com/wp-includes/images/rss.png" alt="RSS" /></a> <a class="rsswidget" href="http://www.cnn.com/index.html">World &#038; National Scene: CNN</a></h2>
<ul><li><a class='rsswidget' href='http://rss.cnn.com/~r/rss/cnn_topstories/~3/EZtqSPaDI60/index.html'>At congressional baseball game, Paul Ryan and Nancy Pelosi project a message of unity after shooting</a></li><li><a class='rsswidget' href='http://rss.cnn.com/~r/rss/cnn_topstories/~3/AF0oK5MrqIs/capitol-hill-police-first-pitch-baseball-game-erin.cnn'>Wounded officer throws out first pitch</a></li><li><a class='rsswidget' href='http://rss.cnn.com/~r/rss/cnn_topstories/~3/BgVkjDYVah8/index.html'>Dems win, then give trophy to Scalise</a></li><li><a class='rsswidget' href='http://rss.cnn.com/~r/rss/cnn_topstories/~3/7TcPAfJYFHk/index.html'>Scalise has improved but is still critical, hospital says</a></li><li><a class='rsswidget' href='http://rss.cnn.com/~r/rss/cnn_topstories/~3/5lZLPT4HMJs/index.html'>Rep. Wenstrup: We all play for the same team</a></li><li><a class='rsswidget' href='http://rss.cnn.com/~r/rss/cnn_topstories/~3/LSNyr6HVOUU/index.html'>SE Cupp: Don&#039;t blame liberals for this tragedy</a></li><li><a class='rsswidget' href='http://rss.cnn.com/~r/rss/cnn_topstories/~3/b3MJ9TtxkOg/index.html'>Mueller investigating Kushner&#039;s business dealings, Washington Post reports</a></li><li><a class='rsswidget' href='http://rss.cnn.com/~r/rss/cnn_topstories/~3/cwXo1ZCu37g/index.html'>Pence hires a lawyer for Russian probe</a></li><li><a class='rsswidget' href='http://rss.cnn.com/~r/rss/cnn_topstories/~3/8d5UOlhCENc/index.html'>Opinion: Prosecute Trump? Not so easy</a></li><li><a class='rsswidget' href='http://rss.cnn.com/~r/rss/cnn_topstories/~3/nrVX-RSmpzE/index.html'>Cillizza: Russia probe moves inside the Oval Office</a></li></ul></li>
<li id="themezee_ads-3" class="widget themezee_ads">			<div class="widget-ads">
									<a  href="http://www.ctba.org/index.cfm"><img src="http://wich.com/wp-content/uploads/2016/09/CBA-1.jpg" alt="banner" /></a>
								<a  href="http://www.hallradio.com/"><img src="http://wich.com/wp-content/uploads/2016/09/Hall-Radio-logo-1.jpg" alt="banner" /></a>
								<a  href="http://www.norwichctevents.com/calendar"><img src="http://wich.com/wp-content/uploads/2017/03/CORE-logo-300x111.png" alt="banner" /></a>
								<a  href="http://wich.com/wp-content/uploads/2016/12/2016-Norwich-Annual-EEO-report-1.pdf"><img src="http://wich.com/wp-content/uploads/2017/03/EEO-Public-File-Report-Banner-1.jpg" alt="banner" /></a>
								<a  href="https://www.roseartsfestival.com/"><img src="http://wich.com/wp-content/uploads/2017/06/Rose-Arts-Festival.jpg" alt="banner" /></a>
						</div>
		</li>
<li id="search-3" class="widget widget_search"><form role="search" method="get" id="searchform" class="searchform" action="http://wich.com/">
				<div>
					<label class="screen-reader-text" for="s">Search for:</label>
					<input type="text" value="" name="s" id="s" />
					<input type="submit" id="searchsubmit" value="Search" />
				</div>
			</form></li>
<li id="google_translate_widget-2" class="widget widget_google_translate_widget"><div id="google_translate_element"></div></li>
		<li id="meta" class="widget widget_meta">			<h2 class="widgettitle"></h2>
			<ul>
						<li><a href="http://wich.com/wp-login.php">Log in</a></li>
			
			
						</ul>
		</li>
	</ul>

	<div class="sidebar-two">
		<ul class="sidebar-left">
					</ul>
		<ul class="sidebar-right">
					</ul>
	</div>
	
	<ul class="sidebar-bottom">
			</ul>
	
	</div>	<div class="clear"></div>
	</div>
</div>
<div id="foot_wrap">
				
		<div id="footer">
			2017 Hall Communications			<div class="credit_link">	<a href="http://themezee.com/">Theme by ThemeZee</a>
</div>
		</div>
		<div class="clear"></div>
</div>
	<!-- ngg_resource_manager_marker --><script type='text/javascript' src='http://wich.com/wp-content/plugins/jetpack/modules/photon/photon.js?ver=20130122'></script>
<script type='text/javascript' src='http://wich.com/wp-content/plugins/custom-facebook-feed/js/cff-scripts.js?ver=2.4.6'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var sb_instagram_js_options = {"sb_instagram_at":"3546370939.3a81a9f.18620c941ef645cba74c267042cdd570"};
/* ]]> */
</script>
<script type='text/javascript' src='http://wich.com/wp-content/plugins/instagram-feed/js/sb-instagram.min.js?ver=1.4.9'></script>
<script type='text/javascript' src='https://s0.wp.com/wp-content/js/devicepx-jetpack.js?ver=201724'></script>
<script type='text/javascript' src='http://s.gravatar.com/js/gprofiles.js?ver=2017Junaa'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var WPGroHo = {"my_hash":""};
/* ]]> */
</script>
<script type='text/javascript' src='http://wich.com/wp-content/plugins/jetpack/modules/wpgroho.js?ver=4.8'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var newsletter = {"messages":{"email_error":"The email is not correct","name_error":"The name is not correct","surname_error":"The last name is not correct","privacy_error":"You must accept the privacy statement"},"profile_max":"20"};
/* ]]> */
</script>
<script type='text/javascript' src='http://wich.com/wp-content/plugins/newsletter/subscription/validate.js?ver=4.9.8'></script>
<script type='text/javascript' src='http://wich.com/wp-includes/js/wp-embed.min.js?ver=4.8'></script>
<script type='text/javascript' src='http://wich.com/wp-content/plugins/joan/joan.js?ver=1.0.0'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var _wp_google_translate_widget = {"lang":"en_US"};
/* ]]> */
</script>
<script type='text/javascript' src='http://wich.com/wp-content/plugins/jetpack/modules/widgets/google-translate/google-translate.js?ver=4.8'></script>
<script type='text/javascript' src='//translate.google.com/translate_a/element.js?cb=googleTranslateElementInit&#038;ver=4.8'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var mc4wp_forms_config = [];
/* ]]> */
</script>
<script type='text/javascript' src='http://wich.com/wp-content/plugins/mailchimp-for-wp/assets/js/forms-api.min.js?ver=4.1.4'></script>
<!--[if lte IE 9]>
<script type='text/javascript' src='http://wich.com/wp-content/plugins/mailchimp-for-wp/assets/js/third-party/placeholders.min.js?ver=4.1.4'></script>
<![endif]-->
<script type='text/javascript'>
/* <![CDATA[ */
var sharing_js_options = {"lang":"en","counts":"1"};
/* ]]> */
</script>
<script type='text/javascript' src='http://wich.com/wp-content/plugins/jetpack/modules/sharedaddy/sharing.js?ver=5.0'></script>
<script type='text/javascript'>
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-facebook', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomfacebook', 'menubar=1,resizable=1,width=600,height=400' );
				return false;
			});
</script>
<!-- Custom Facebook Feed JS -->
<script type="text/javascript">
var cfflinkhashtags = "true";
</script>
	<div style="display:none">
	</div>
<script type="text/javascript">(function() {function addEventListener(element,event,handler) {
	if(element.addEventListener) {
		element.addEventListener(event,handler, false);
	} else if(element.attachEvent){
		element.attachEvent('on'+event,handler);
	}
}function maybePrefixUrlField() {
	if(this.value.trim() !== '' && this.value.indexOf('http') !== 0) {
		this.value = "http://" + this.value;
	}
}

var urlFields = document.querySelectorAll('.mc4wp-form input[type="url"]');
if( urlFields && urlFields.length > 0 ) {
	for( var j=0; j < urlFields.length; j++ ) {
		addEventListener(urlFields[j],'blur',maybePrefixUrlField);
	}
}/* test if browser supports date fields */
var testInput = document.createElement('input');
testInput.setAttribute('type', 'date');
if( testInput.type !== 'date') {

	/* add placeholder & pattern to all date fields */
	var dateFields = document.querySelectorAll('.mc4wp-form input[type="date"]');
	for(var i=0; i<dateFields.length; i++) {
		if(!dateFields[i].placeholder) {
			dateFields[i].placeholder = 'YYYY-MM-DD';
		}
		if(!dateFields[i].pattern) {
			dateFields[i].pattern = '[0-9]{4}-(0[1-9]|1[012])-(0[1-9]|1[0-9]|2[0-9]|3[01])';
		}
	}
}

})();</script><div id="fb-root"></div>
			<script>(function(d, s, id) { var js, fjs = d.getElementsByTagName(s)[0]; if (d.getElementById(id)) return; js = d.createElement(s); js.id = id; js.src = 'https://connect.facebook.net/en_US/sdk.js#xfbml=1&appId=249643311490&version=v2.3'; fjs.parentNode.insertBefore(js, fjs); }(document, 'script', 'facebook-jssdk'));</script>
			<script>
			jQuery( document.body ).on( 'post-load', function() {
				if ( 'undefined' !== typeof FB ) {
					FB.XFBML.parse();
				}
			} );
			</script>
						<script>!function(d,s,id){var js,fjs=d.getElementsByTagName(s)[0],p=/^http:/.test(d.location)?'http':'https';if(!d.getElementById(id)){js=d.createElement(s);js.id=id;js.src=p+'://platform.twitter.com/widgets.js';fjs.parentNode.insertBefore(js,fjs);}}(document, 'script', 'twitter-wjs');</script>
						<script>
			function renderGooglePlus1() {
				if ( 'undefined' === typeof gapi ) {
					return;
				}

				jQuery( '.g-plus' ).each(function() {
					var $button = jQuery( this );

					if ( ! $button.data( 'gplus-rendered' ) ) {
						gapi.plusone.render( this, {
							href: $button.attr( 'data-href' ),
							size: $button.attr( 'data-size' ),
							annotation: $button.attr( 'data-annotation' )
						});

						$button.data( 'gplus-rendered', true );
					}
				});
			}

			(function() {
				var po = document.createElement('script'); po.type = 'text/javascript'; po.async = true;
				po.src = 'https://apis.google.com/js/plusone.js';
				po.innerHTML = '{"parsetags": "explicit"}';
				po.onload = renderGooglePlus1;
				var s = document.getElementsByTagName('script')[0]; s.parentNode.insertBefore(po, s);
			})();

			jQuery( document.body ).on( 'post-load', renderGooglePlus1 );
			</script>
			<script type="text/javascript" src="https://platform.tumblr.com/v1/share.js"></script>	<div id="sharing_email" style="display: none;">
		<form action="/2017/06/15/thursday-evening-update/" method="post">
			<label for="target_email">Send to Email Address</label>
			<input type="email" name="target_email" id="target_email" value="" />

			
				<label for="source_name">Your Name</label>
				<input type="text" name="source_name" id="source_name" value="" />

				<label for="source_email">Your Email Address</label>
				<input type="email" name="source_email" id="source_email" value="" />

						<input type="text" id="jetpack-source_f_name" name="source_f_name" class="input" value="" size="25" autocomplete="off" title="This field is for validation and should not be changed" />
			<script>jQuery( document ).ready( function(){ document.getElementById('jetpack-source_f_name').value = '' });</script>
			
			<img style="float: right; display: none" class="loading" src="http://wich.com/wp-content/plugins/jetpack/modules/sharedaddy/images/loading.gif" alt="loading" width="16" height="16" />
			<input type="submit" value="Send Email" class="sharing_send" />
			<a rel="nofollow" href="#cancel" class="sharing_cancel">Cancel</a>

			<div class="errors errors-1" style="display: none;">
				Post was not sent - check your email addresses!			</div>

			<div class="errors errors-2" style="display: none;">
				Email check failed, please try again			</div>

			<div class="errors errors-3" style="display: none;">
				Sorry, your blog cannot share posts by email.			</div>
		</form>
	</div>
<script type='text/javascript' src='https://stats.wp.com/e-201724.js' async defer></script>
<script type='text/javascript'>
	_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:5.0',blog:'104285149',post:'5234',tz:'-4',srv:'wich.com'} ]);
	_stq.push([ 'clickTrackerInit', '104285149', '5234' ]);
</script>
</body>
</html>